Ayatah | Configure Router on Stick كيفية إعداد التوجيه بين ال VLANs

Configure Router on Stick كيفية إعداد التوجيه بين ال VLANs

بتاريخ: 2021-06-10     من طرف: عيادي طاهر


تستعمل الشبكات المحلية الإفتراضية لغرض تقسيم نطاق البث Broadcast range داخل قسم معين، فمثلا VLAN Voice خاص بأجهزة الاتصالات، VLAN Data لنقل البيانات VLAN Client للمستخدمين... وغيرها من الأمثلة.. وهذا بهدف عزل بعض الأجهزة المتصلة عن بعضها البعض أو عزل نقل البيانات لتخصيص الأولوية لفئة معينة،وكذلك لتطبيق بعض بروتوكولات الحماية الأولية.

تقوم المحولات Switches بتقسيم مجال البث Broadcast عبر VLAN (شبكة محلية افتراضية).و VLAN هو مجال بث مقسم من مجال بث واحد. لا يقوم الموجه Router بإعادة توجيه الحزم عبر شبكات محلية ظاهرية مختلفة بمفرده. إذا أردنا أن نجعل شبكات VLAN الافتراضية هذه تتواصل مع بعضها البعض ، يجب علينا أن نقوم ببعض الإعدادات على الموجه وهو ما يعرف بمفهوم Inter VLAN Routing.

تجدر الإشارة أن الموجه Router بإمكانه تحمل توجيه الى غاية 50 شبكة محلية ، وهو أكثر من كاف في البيئات الصغيرة والمتوسطة. كما يجب التنبيه الى أن هذه الطريقة تستعمل حصرا مع الروترات القديمة أو التي لا تدعم التحويلُ EtherSwith Router ، أو إذا لم تتوفر هناك محولات من الطبقة الثالثة L3 Switch التي تدعم التوجيه وهي أسرع بكثير من محولات الطبقة الثانية L2 Switch.

سيناريو عملي:

لنفترض أن لدينا ثلاث شبكات إفتراضية، وهي كالتالي :

VLAN 1 : Native وهي تأتي ضمن الأعدادات الإفتراضية و تعرف بإسم Native Vlan ، جميع الأجهزة المتصلة بهذه الشبكة تحمل عناوين IP في نطاق 10.16.1.0/24.

VLAN 10 : Satatic تخصص للأجهزة الثابتة والخوادم Servers ، جميع الأجهزة المتصلة بهذه الشبكة تحمل عناوين IP في نطاق 10.16.10.0/24.

VLAN 20 :VOIP تخصص للأجهزة الناقلة للصوت أو ما يعرف VOIP (Voice Over IP ) ، جميع الأجهزة المتصلة بهذه الشبكة تحمل عناوين IP في نطاق 10.16.20.0/24.

كما هو مبين في الشكل التالي:

سيناريو عملي لتطبقات الشبكات المحلية الإفتراضية VLANs
سيناريو عملي لتطبقات الشبكات المحلية الإفتراضية VLANs

تقسيم المنافذ والعناوين كما هو مبين في الجدول التالي:

vlan port range IP Address
VLAN 1 g0/1-3 10.16.1.1-254
VLAN 10 g1/0-3 10.16.10.1-254
VLAN 20 g2/0-3 10.16.20.1-254
R1 g0/0.1 10.16.1.1
R1 g0/0.10 10.16.10.1
R1 g0/0.20 10.16.20.1

كل من الموجه Router R1 والمحول Switch S1 لا يحتويان على أي إعدادات مسبقة.

نقوم بإنشاء الشبكات الإفتراضية على مستوى Switch S1 :

          S1#configure terminal
          S1(config)#vlan 10
          S1(config-vlan)#name STATIC
          S1(config-vlan)#exit
          S1(config)#vlan 20
          S1(config-vlan)#name VOIP
          S1(config-vlan)#exit
          S1(config)#^Z
          S1#
         

نتأكد من أنه تم إنشاء VLAN 10 و VLAN 20 :

إنشاء VLAN 10 و VLAN 20
إنشاء VLAN 10 و VLAN 20

نبدأ بتوزيع المنافذ على مختلف الأجهزة وجعلها في نظام access mode :


          S1#configure terminal
          S1(config)#interface range g1/0-3
          S1(config-if-range)#switchport mode access
          S1(config-if-range)#switchport access vlan 10
          S1(config-if-range)#interface range g2/0-3
          S1(config-if-range)#switchport mode access
          S1(config-if-range)#switchport access vlan 20
          S1#sh vlan brief
          
نلاحظ في الصورة التالية أنه تم إعادة توزيع 4 منافذ في كل VLAN :
توزيع المنافذ الخاصة بالمحول Switch S1
توزيع المنافذ الخاصة بالمحول Switch S1

نقوم بتوزيع عناوين IP على مختلف الأحهزة :

Client IP Address Gateway
PC1 10.16.10.11 10.16.10.1
PC3 10.16.10.12 10.16.10.1
PC2 10.16.20.21 10.16.20.1
PC4 10.16.20.22 10.16.20.1
PC5 10.16.1.5 10.16.1.1
PC6 10.16.1.6 10.16.1.1

نقوم بإنشاه واجهات فرعية sub interfaces على الراوتر:


          R1(config)#interface g0/0.1
          R1(config-subif)#encapsulation dot1Q 1 native
          R1(config-subif)#ip address 10.16.1.1 255.255.255.0
          R1(config-subif)#interface g0/0.10
          R1(config-subif)#encapsulation dot1Q 10
          R1(config-subif)#ip address 10.16.10.1 255.255.255.0
          R1(config-subif)#interface g0/0.20
          R1(config-subif)#encapsulation dot1Q 20
          R1(config-subif)#ip address 10.16.20.1 255.255.255.0
      
نتحقق من قائمة المنافذ الجديدة:
إنشاء واجهات فرعية Subinterfaces على R1
إنشاء واجهات فرعية Subinterfaces على R1

نحول منفذ g0/0 على Switch S1 الى trunk :


          S1(config)#int g0/0
          S1(config-if)#switchport trunk encapsulation dot1q
          S1(config-if)#switchport mode trunk
        
<ح>نلاحظ أنه تم تحويل المنفذ g0/0 الى trunk ، وكل ال VLANs مسموح لها المرور 1،10،20 :
إنشاء واجهات فرعية Subinterfaces على R1
التحقق من منافذ Trunk

الآن يمكن أن نتحقق أنه توجد اتصال بين جميع الأجهزة:

اتصال بين PC1(vlan10) و PC4(vlan20)
اتصال بين PC1(vlan10) و PC4(vlan20)
اتصال بين PC5(vlan1) و PC3(vlan10)
اتصال بين PC5(vlan1) و PC3(vlan10)

وبهذا نكون قد أنهينا إعدادات الموجه R1 لتدعيم خاصية Inter VLAN Routing .